Friday, 5 February 2016

Unattended updates on Linux MINT

Updates in MINT have been quite reliable within the last years. Thus having a little more comfort is from my perspective preferable. The MINT forum offers first steps to have unattended updates.

/etc/apt/apt.conf.d/10periodic
  • APT::Periodic::Update-Package-Lists "1";
  • APT::Periodic::Download-Upgradeable-Packages "0";
  • APT::Periodic::AutocleanInterval "30";
  • APT::Periodic::Unattended-Upgrade "1";
/etc/apt/apt.conf.d/50unattended-upgrades
    • "Ubuntu trusty-security";
    • "Ubuntu trusty-updates";
    • "linuxmint rosa";
    • "LP-PPA-webupd8team-java trusty"; //Oracle Java
    •  LP-PPA-peterlevi trusty"; //Variety
    • "liveusb.info all"; //MultiSystem
    • "Canonical trusty"; //Adobe & more
    • "LP-PPA-gencfsm trusty" //gnome-encfs-manager
    These are the sources that I need to cover all my applications. Andrew gives advice, how to identify these sources at least roughly. Keep in mind! The sources need to be partially updated after an upgrade.
    sudo unattended-upgrade --dry-run --debug | awk -F "\'" '/Origin component/{print $11,$9}' | sort | uniq
    /var/log/unattended-upgrades

    Here you find the regular created log files. Worth watching when starting with the unattended upgrades.

    Monochrome Dropbbox icon

    Having a NVIDIA graphic card the Dropbox icon can have an ugly black background. This is annoying when using e.g. Linux Mint with Cinnamon or MATE.

    However I found a reddit post with the solution:
    1. Quit Dropbox
    2. Go into ~/.dropbox-dist/dropbox-lnx[VERSION] 
    3. Backup libGL.so.1
    4. Delete libGL.so.1
    5. ln -s /usr/lib/nvidia-[VERSION]/libGL.so.1 /home/[ACCOUNT]/.dropbox-dist/dropbox-lnx[VERSION]/
    6. Start Dropbox
    Now the Dropbox icon should have a transparent background again.

    Tuesday, 12 January 2016

    Asus UX305CA and Mint 17.3 Rosa

    While my old Asus notebook has been almost five years old, it was time for a new one. Mostly because of heat issues the notebook had the past month.

    Looking at the Asus Zenbook series I really felt in love with the UX305 platform. The UX305FA is a fan-less and light notebook, however the CPU performance could have been more powerful. So I bought the successor UX305CA, knowing that the new Intel Skylake chipset has not a full Linux support yet. Nevertheless it is a great piece of hardware!

    Known issues however are:
    • Touchpad is not working, but workaround available
    • Brightness keys are not working, but softkey configuration possible
    In addition I faced some challenges before everything worked fine. Here my journey so far:
    • Using a MultiSystem USB Stick I had to disable "Secure Boot" in the BIOS to be able to boot from the stick
    • Loading the Live CD with Mint 17.3 Rosa the touchpad was not working. Connect a mouse
    • Upgrade the kernel after installation to 4.4.0 
    • Compile your own 4.4.0 kernel with touchpad support
    • Configure grub or use Grub Customizer to start from your customized kernel
      • Restore grub, if something went wrong by doing it manually


    Dropbox encryption: cryptkeeper alternative

    Using cryptkeeper has been often very frustrating, because of "segmentation fault" issues. The tool often didn't start at start-up and had to be started manually. Even this took sometimes several attempts due to "segmentation fault" messages.

    However there are other solutions out. Just make your life easier and use Gnome Encfs Manager.

    Saturday, 27 December 2014

    MP550 und MINT 14.04 LTS 32-bit

    It is always an adventure to install a printer. This time "libtiff4" is missing, because it is not more available in 14.04. libtiff5 is the new version.

    Thus the "cnijfilter-mp550series_3.20-1_i386.deb" package needs to be adjusted to get the dependencies to work:

    1. dpkg -x [package].deb common
    2. dpkg --control [package].deb
    3. nano DEBIAN/control
    4. replace the "Depends" line with:
    Depends: cnijfilter-common (>= 3.20-1), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.7), libcupsys2 (>= 1.2.1) | libcups2, libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.35.9), libgtk2.0-0 (>= 2.8.0), libpng12-0 (>= 1.2.13-4), libpopt0 (>= 1.14), libtiff5 (>= 4.0.3), libxml2 (>= 2.7.4)
    5. cp -a DEBIAN/ common/
    6. dpkg -b common [package].deb
    7. rm -rf common DEBIAN
    8. Now run the install script!
    Thanks to askubuntu!

    The scanner installation (Scangear) went this time smooth and without any issues. What a relief!

    Sunday, 15 June 2014

    HD video and 5.1 surround sound with Linux Mint MATE 14.04 LTS

    In my previous posts concerning the configuration of mplayer and the surround sound a lot of manual work had to be done. This time it seems to be a little bit easier.

    HD video

    mplayer2 is a fork of mplayer and is available in the Software Manager.
    The mplayer2 configuration file is now under /home/"USER"/.mplayer and named config. Add:
    vo=vdpau
    vc=ffh264vdpau
    fs=yes
    aspect=16:9
    Make mplayer your default video player.

    Surround sound

    Switch in your Sound Preferences from Analog Stereo to Digital Surround 5.1 (HDMI) Output.

    Testing your surround channels with a test file (e.g. chain-id.wav) everything sounds right. Using the build-in audio check the channel order is wrong.

    Why?

    I did not open the chain-id.wav with mplayer! If you do so the order is still wrong. Add in addition to the previous entries this to the mplayer config file:
    # 5.1 surround sound 
    channels=6 
    # Using correct sound device 
    ao=alsa:device=hw=0.3 
    # For both AC-3 and DTS passthrough
    afm=hwac3
    Now my videos look and sound great again!

    Tuesday, 10 June 2014

    Variety: Substitution for background changer Webilder

    My lovely background changer Webilder is not working with Mint MATE anymore. Fortunately a very good substitution is available.

    Variety has even more options than Webilder and is easy to install and to use.

    • sudo add-apt-repository ppa:peterlevi/ppa
    • sudo apt-get update
    • sudo apt-get install variety
    Enjoy!