Tuesday, 18 October 2011

MP560 and 11.10 64-bit

It was also tricky with 11.04, but as far as I remember it took not so much time. Now 11.10... You know the feeling after reaching something that took you a lot of effort? I guess you know it :-) !!!

Several stages are to overcome to install the Canon MP560 on 64-bit properly:

1. Download files from Canon Asia or Canon Europe. You need
MP560 series ScanGear MP Ver. 1.40 for Linux (debian Packagearchive) and
MP560 series IJ Printer Driver Ver. 3.20 for Linux (debian Packagearchive).
  
2. Both files contain a install.sh script. Likely you will receive this the error message when executing the script:

==================================================  
Canon Inkjet Printer Driver Ver.3.20-1 for Linux 
Copyright CANON INC. 2001-2009 
All Rights Reserved. 
================================================== 
Error! Cannot specify package management system.

You get the error only when both dpkg and rpm exist on your system. So far I cannot remember this message from my installation with 11.04.
## Judge is the distribution supporting rpm? ##
rpm --version 1> /dev/null 2>&1 c_system_rpm=$?
Change rpm –version to e.g. rpm-not-active --version or something else. So the script skips this procedure.

Thanks to Mark

3. Now we have to take care about the dependences. The scripts use --force-architecure, however that is not enough when packages are missingThe system told me e.g. that cnijfilter-common:i386 depends on libpopt0 (>= 1.7).
For each package do the following:
1. dpkg -x [package].deb common
2. dpkg --control [package].deb
3. nano DEBIAN/control
4. remove the whole "Dependency:" line
5. cp -a DEBIAN/ common/
6. dpkg -b common [package].deb
7. dpkg --force-all -i [package].deb
8. rm -rf common DEBIAN
The install.sh script should work properly now. And for the next installation save the modified package, because you can use them again!

Thanks to askubuntu.com

4. The printer was now recognized. Printing not tested yet due to empty cartridges. But printing itself was the last time not the major issue. Scanning was more important to me. I restarted and looked into GIMP for the ScanGear MP plugin. At first it was not there! Starting scangearmp on the shell showed me why.
scangearmp: error while loading shared libraries: libgimp-2.0.so.0: wrong ELF class: ELFCLASS64
What now? After quite some searching the answer. wrong ELF class: ELFCLASS64 means that 32-bit version of libgimp tries to run on a 64-bit system. Did the Canon driver overwrite my 64-bit files or made the 32-bit version primary? I reinstalled over Synaptic the package libgimp2.0 and voila! scangearmp runs now and the GIMP plugin is also available. 

What a day... 

EDIT: Due to my reinstallation I tried to reinstall libgimp2.0 over Synaptic again. But this was not enough. I had to download the 32-bit driver from here and extract it with
dpkg -x libgimp2.0_2.6.11-2ubuntu4_i386.deb ~/Downloads
An installation of libgimp2.0:i386 over Synaptic won't work. Copy then the files manually from ~/Downloads/usr/lib to /usr/lib and /usr/lib32. Afterwards reinstall libgimp2.0 over Synaptic. Strange, but now it works again.

Update: Copying ~/Downloads/usr/lib to /usr/lib is sufficient for scanning. Do a backup of libgimp* in advance.


After the printer driver installation some days ago I didn't try to test the printer. Now I tried to print and there are still some things to do. Printing failed with error cups-insecure-filter. Do the following to get rod of the last obstacle:
sudo chown root:root /usr/lib/cups/filter/pstocanonij
sudo chown root:root
/usr/lib/cups/backend/cnijnet
This sets finally wrong given rights correctly and you can print ongoing without any further errors.

2 comments:

  1. do you have any idea how to solve scangearmp on ubuntu 12.10 x64 - I'm now thanks to you that far that I seem just to struggle with

    Gtk-Message: Failed to load module "overlay-scrollbar"
    `menu_proxy_module_load': scangearmp: undefined symbol: menu_proxy_module_load

    (scangearmp:6462): Gtk-WARNING **: Failed to load type module: (null)
    ....

    ReplyDelete
    Replies
    1. Hi G.,

      I do not know that error message in particular, but after a little search I found this bug report: https://bugs.launchpad.net/ubuntu/+source/overlay-scrollbar/+bug/1134202
      Try: sudo apt-get install overlay-scrollbar

      Delete